You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
The Support Center is currently under construction.  If you have a support request, please use the "create a new ticket" link below or send an email to [email protected] with the details. 
announcement close button
Home > 4. FAQs > What are the technical requirements for Carnegie Speech software?
What are the technical requirements for Carnegie Speech software?
print icon

For NativeAccent 4, Carnegie BASICS, and Carnegie Speech Assessment

  1. Supported devices include:
    1. Computers with either Windows 7.8 or 10 or macOS (headset recommended)
    2. Chromebooks (earbuds or headset recommended)
    3. Mobile devices including phones and tablets running iOS and Android operating systems (earbuds recommended)
  2. Browsers
    1. Supported:  current versions of Google Chrome (recommended), Mozilla Firefox, Microsoft Edge, and Apple Safari (required for iOS devices).
Feedback
0 out of 3 found this helpful

scroll to top icon